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Tasks - The Tasks dialog is the default task navigation interface. It is docked to left side of the application window. The Main 
toolbox is embedded along the top. 

 

By default, the Tasks dialog is docked on the left side of the application window and the active task is the Drawing task. Other 
available tasks are shown as tabs. Clicking the arrow next to Tasks, at the top of the dialog, opens a menu that lists all tasks in a 
hierarchical tree. Clicking a task in the tree makes it the root task, hiding the other tasks. Using this mode, you can see all the 
tools in the sub‐tasks. 

The task tabs have icons that let you change the way tools are presented. The default layout mode is the Panel layout. You can 
click the icons to view the tools in Icon layout mode or List layout mode. Panel layout mode shows the tool icons and the 
keyboard shortcuts.  In Icon layout mode, tasks appear most like traditional toolboxes.  List layout mode provides the most 
information because the tool name is included. The icon belonging to the first tool in a task is displayed on the task's tab. 
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In the following exercise, Tasks will be explored and reviewed. 

Exercise:  Review Tasks 

1. Start MicroStation, set workspace to Examples/General/Default 

2. Open User Interface.dgn 

3. Note and explore tasks on left side. 

4. Note and explore layout options 

 

Workflow Tasks - A workflow can consist of one or more tasks. In most cases, a workflow consists of a collection of tasks 
organized in the order that you will use them to complete a project or job. Each task contains the tools you need to complete the 
task. Workflows have a Workflow icon on their tab. An example for building a town is given in the General project. 

The Drawing Composition workflow task is made up of tasks organized in a logical order for working with drawing composition 
and dynamic views. Dynamic views is a name that encompasses related MicroStation features that make model analysis more 
interactive and intuitive. There are Organize (Project Explorer, link set, Select Elements with Links), Drawing, Design 
Composition (create a new file or model, attach references), Create Views (manage levels, clip volumes, saved views and view 
attributes), Sheet Composition (create sheet models and define sheet boundaries, attach references), and Annotate tasks. 

In the following exercise, a workflow will be explored. 

 

Exercise:  Review Workflows 

1. Continue in User Interface.dgn 

2. Expand the available tasks and choose Town Task Example 
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Note that this workflow consists of a Build Town task. 

 

 

3. Select Create New Town.  Choose Design From Seed.   . 

4. Explore the tasks contained within the Build Town workflow. 

5. Set the view to TOP for easier placement of the town components. 

6. Using the tools presented in the Build Town task, place several components. 

7. Explore the remaining tool bars in the Town Task example. 

Presentation Preferences - The size of the icons in the Tasks dialog can be set in the Task Navigation category of the 
Preferences dialog. A check box lets you show or hide the Main toolbox that is part of the Tasks dialog. You can also change the 
layout back to the V8 XM Edition default.  

 

 

In the following exercise, the presentation of the tasks will be changed. 
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Optional Exercise:  Presentation Preferences 

1. Continue in User Interface.dgn 

2. Select Workspace > Preferences > Task Navigation > Presentation 

3. Change to Tool Box. 

4. Dock the Tasks and Main toolboxes. 

5. Close the file. 

Status Bar - Right click in the status bar, away from the Message Center area, to open a menu that lets you select the sections 
of the status bar you want to display.  

 

If you display the Running Coordinates section of the status bar, as you move the pointer, the coordinates of the current position 
display, related to the active snap mode. If you left click in the area, a menu opens. The Delta modes show the X, Y, and Z 
displacement from the last data point. The Distance modes show the distance and direction from the last data point. If you left 
click the Running Coordinates section then the following menu appears. 

 

In the following exercise, the display of running coordinates will be enabled. 
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Exercise:  Status Bar 

1. Continue in User Interface.dgn 

2. Right click the status bar, and enable the display of Running Coordinates 

 

 

Docking - Docking indicators appear on the screen when you begin to move a dockable dialog. When you drag it over one of the 
docking indicators, it highlights an available docking region where the dialog will be placed along the corresponding edge of the 
application window. Release the mouse button when you like the position, and the dialog becomes docked there. 

 

 

Element Selection - Enhancements to selection include additional options on the Element Selection tool and drag support 
during the use of manipulation tools.   

The Shift key is a toggle that changes an inside selection to an overlap, or an overlap to an inside.  Dragging the selection box 
from right to left is overlap and from left to right is inside.  

Five attributes tabs, hidden by default, are added to the Element Selection tool.  

 

 

To display them right click on the attributes tabs in the tool settings and turn on the desired attributes. And, after selecting a 
manipulation tool, you can select multiple elements by dragging a shape around them. 

In the following exercise, changes to the Element Selection dialog will be explored. 
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Exercise:  Element Selection 

1. Set the following in the File Open dialog: 

User: Examples 

Project: General  

2. Open Element Manipulation.dgn 

3. Hover the cursor over any element in the bathroom and right click. 

4. Select Exchange from the popup menu... 

5. Select the Element Selection tool. 

6. In the tool settings, right click and enable the display of the new tabs. 

7. Drag a box around the graphics from left to right.  Only those inside the box are selected. 

8. Release the selection set. 

9. Drag a box from right to left, and all overlapping graphics are added. 

10. Release the selection set. 

 

Exercise:  Selecting elements for manipulation without creating a selection set 

11. Select an element manipulation tool such as Move. 

12. Now select the elements. 
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Modify Tools – The Trim Element tool has been renamed Trim Multiple, and Trim, Extend, and Trim and Extend modes have 
been added to the tool settings.  

 Trim is the default mode and works basically the same as the old Trim Element tool.  

 Extend mode is borrowed from the IntelliTrim tool.  

 Trim and Extend is a new mode altogether which lets you trim and extend one or more elements at their intersection with 
the cutting element.  

Regardless of which mode you are in, after you select the cutting element, the enhanced Trim Multiple tool lets you select 
multiple elements by dragging a selection line across them, so you can simultaneously trim, extend, or trim and extend them at 
their intersection with the cutting element. 

The Extend Element to Intersection tool has been renamed Extend To Element. The default behavior of the enhanced Extend To 
Element tool remains the same as before. However, a new tool setting has been added which lets you invert the element 
identification behavior, so that the first element you identify is now the cutting element, and the second element you identify is the 
element that gets extended or shortened. When this tool setting is on, after you select the cutting element, you can select 
multiple elements by dragging a selection line across them to simultaneously extend and/or shorten them.  

The Extend Two Elements to Intersection tool has been renamed Extend To Intersection, and has been enhanced to let you 
extend or shorten two elements of any type to their intersection. 

In the following exercise, changes to the Trim tools will be explored. 
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Exercise:  Trim Elements 

1. Open MicroStation Essentials V8i.dgn 

2. From the Models dialog, navigate to:  Modifying Existing Elements Challenges 

3. Zoom to the grouping showing the cyan circles and lines. 

4. Open Modify task as a toolbox. 

 

 In the following steps, the left side of the circle will be trimmed off as shown below: 

 

 

 

 

 

 

 

 

5. Select Trim Multiple with the Mode set to Trim 

6. Enter a data point on the line, then a data point on the portion of the circle to remove. 
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In the following steps, two horizontal lines will be trimmed as shown below.  The right side of the top line will be removed, 
and the left side of the bottom line will be removed. 

 

 

 

 

 

 

 

7. Select Trim to Element, with the Select Cutting element first turned off. 

8. Enter a datapoint on the portion of an element that is to be deleted. 

9. Hold the CTRL key down and enter subsequent datapoints on those portions to delete. 

10. Release the CTRL key, and enter a data point on the cutting element. 
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In the following steps, the horizontal lines that pass through the bottom circle will be trimmed to result in the following: 

 

 

 

 

 

 

 

 

11. Select Trim Multiple and set the mode to Trim 

12. Select the lower circle. 

13. Then drag a line through the elements to trim. 
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Clip Volumes - A clip volume encloses a space. You can create a clip volume to focus on certain parts of a model and hide the 
rest. When a clip volume is applied to a view, only elements that are located within the clip volume will display. The most 
common clip is called a section clip. A section clip is often associated to a section callout. The area outside the volume is called 
outside. A clip volume has a section plane passing through it. Material inside the volume that is behind the section plane is 
backward, while material that is in front of the section plane is forward. Section graphics are produced wherever the section 
plane intersects material inside the clip volume. 

To create one, in the active view's view controls, click 
the Clip Volume tool, select Apply or Modify Clip 
Volume and set the tool settings. 

 

 

 

 

 

The clip volume produces section graphics along the cut plane. The term section graphics refers to the lines, arcs, and curves 
displayed in a view after you create a clip volume that cuts through a solid, surface, or mesh. Curves are defined by the 
intersection between the clip volume faces and the original elements. You can modify the depths and clipping parameters of the 
clip volume by selecting the clip volume. The green arrow edit handle lets you move the clip plane laterally and flip the clip 
direction. 

The side edit handles allow you to move the side clip distances 
and turn off the clipping of one or more sides. 
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You can control the display of each category of geometry separately by assigning different display styles to each category in the 
Clip Volume Settings section of the View Attributes dialog. Each category has its own viewing symbology, can be turned on or 
off, and can be made locatable or not. Display styles are created and managed in the Display Styles dialog. 
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In the following exercise, a clip volume will be created. 

 

Exercise:  Create Clip Volume 

1. Open Graphics Display.dgn  and navigate to the Engine model 

2. From the Saved View dialog, apply the Illustration view to View 1. 

3. From the view control tool bar, select Apply or Modify Clip Volume   

4. In the tool settings, select Section Clip Tools  and XZ Plane:  

5. Enter a data point on the view. 

6. Drag the green bolt to define the section cut. 

7. Enter a data point to accept the cut. 

 

8. From the view control bar, choose Clear Active Clip Volume 

9. Enter a data point on the view. 
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Display Styles - In the MicroStation V8 XM Edition you applied a view display mode with companion settings on a per‐view 
basis. In MicroStation V8i, you apply a Display Style that includes the display mode and other settings, including optional 
overrides. A display style consists of a shading mode plus other settings and overrides that you can specify. Display styles are 
created and managed in the Display Styles dialog. They are typically saved as shared resources in DGN libraries. Display styles 
apply to saved and dynamic views, as well as normal views. 

 

The following exercise explores the use of display styles. 

Exercise: Use Display Styles 
1. Continue in Graphics Display.dgn. 

2. Click and hold on the View Display Mode icon in the view controls. 

 

  

 

 

 

 

 

 

3. Try some of the default Display Styles. 

4. Close the file. 

 

 

 

 

 

 



                   IBUG Fall User Group Meeting September 28th 2011 
 

        © 2011 Bentley Systems, Incorporated.    
     

16

 

 

Saved Views - A saved view is a view definition, which includes the level display for the active model and references, the clip 
volume, and other view attributes. The saved level display states are view specific and are copied from the source view window 
that was used to create the saved view. The view definition is given a name and saved in the DGN file. You create the definition 
by setting up a source view as a template and saving it. The saved view can be applied to a destination view window. 

The Saved Views dialog is used to create, update, apply, import, and delete saved views and edit properties of saved views.  
The Saved Views dialog can be opened from the Primary Tools toolbox. 

 

 

 

 

The Saved Views dialog's Apply Options section has been moved to a new tool settings window called Apply Saved View. Set 
the tool settings and enter a data point in the desired view or choose to display in all views.  

 

The saved view graphics can be selected with the Element Selection tool, or by a fence, and manipulated like a regular element. 
Picture frame graphics in the corners, help you to a Saved View, if the View Attribute Boundary Display is turned on. 
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In the following exercise, a saved view will be created and applied. 

 

Exercise: Use the Saved View functionality 

1. Change the workspace to Examples / Geospatial 

2. From the Sheets folder, open BSI200‐M01‐City.dgn. 

3. Zoom in to any portion of the map. 

 

 

4. In the Saved View dialog, click Create Saved View, use the method From View, enter a name, and turn on Associative Clip 
Volume.  

5. Enter a data point in the view to create the Saved View. 

 

In the following exercise, the frame of a saved view will be modified. 
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Exercise: Saved view 

1. Continuing in the same file, fit the view. 

2. In the Saved Views dialog, click in the Show column.  A frame displays showing the extents of the saved view. 

3. Using the Element Selection tool, move and change the size of the frame. 

4. Apply the saved view to the view.  

5. In the Saved Views dialog, uncheck the Show column. 

6. Fit the view 

 

Note:  An alternate workflow is to first create a named clip volume and then create a saved view of the clipped volume. 

 

 

 

Right click context menus - MicroStation lets you customize its context menus. Context menus are the menus accessed by 
clicking the right mouse button, and custom context menus are added to the reset popup menu. You can create custom context 
menus by copying standard menus and menu items or by creating new menus and menu items. Right press menus allow 
dynamic functionality. The menu changes depending on what element type you right click. To right click on an element, you must 
put the pointer on the element and hold the right mouse button, reset button, for more than one‐sixth of a second. 

 

Exercise:  Right Click menu 

1. Open /sheets/BSI200-M06-Wards.dgn 

2. Select Element Selection 

3. Right click on the frame around the logo at the upper left. 

4. Choose Fit to View and enter a datapoint.  The raster logo is fitted to the view. 

5. Zoom out or fit the view to see the text City of Peterborough 

6. With the Element Selection active, right click the text and choose Edit Text 

7. Right click other elements taking note of available options. 
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View Attributes - The View Attributes dialog allows you to apply a selected display style to a specific view or to all views. Added 

sections allow you to set global brightness, apply a saved view to a model, and view the forward, back, cut, outside clip volume. 

The following exercise illustrates how to view multiple models. 

 

 

Exercise: Viewing multiple models 

1. Open /Design/BSI200‐R02‐Land 
Acquisition.dgn from the Design folder. This is 
a multi-model design file. 

2. Open and tile Views 2 through 4. 

3. Open the View Attributes dialog. 

4. Expand the View Setup section at the bottom 
of the dialog. 

5. At the top of the dialog, change the View 
Number to 2. 

6. In the View Setup section, select the Limit 
model. 

7. Change the View Number to 3. 

8. In the View Setup section, select the Wards 
model. 

9. Change the View Number to 4. 

10. In the View Setup section, select the Park model. 

11. Fit all views. 
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Shapefile - MicroStation V8i SS2 now supports the attachment and opening of SHP, and MIP/MIF files.  Shapefiles require at 
least three files in the same directory, with the same name and with the following extensions:  SHP (geometry), SHX (index), and 
DBF (attributes).  Shapefiles can have an associated geographic coordinate system that’s described in an accompanying PRJ 
file.  To view this information in MicroStation, open the file as you would any other design file.  When a shapefile, or other 
supported GIS files are opened in MicroStation, they are opened for “read-only” access, meaning you cannot save updates back 
to those formats.   

The following exercise describes how to attach and view graphical data in a shapefile. 

 

Exercise:  Attaching a SHP file 

1. Navigate to Examples/Geospatial 

2. Open  BSI200-R01-Environmental.dgn from the Designs folder 

3. Select Attach Reference. 

4. Navigate to the /geospatial/data/shp/ folder and note the addition of  Shapefiles (*.shp) in the Files of type option. 

 

5. Select and attach ORN_Peterborough.shp with the Attachment Method set to Geographic – Reprojected. 

 

 

6. Hover the cursor over an element from the attached SHP file and select Exchange from the right click menu. The file opens 
in read-only mode and in the projection defined by the accompanying PRJ file. 

 

7. Close the file. 
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Geo-coordination - Geo‐coordination features let you specify the position of design contents on the earth’s surface. Once that 
position is established, a design can be coordinated with other data for which the geographic location is known.  For more 
information, please refer to the following wiki article: 

http://communities.bentley.com/Wiki/view.aspx/Assigning_A_Geographic_Coordinate_System 

There are several ways to apply a geographic coordinate system to a model: By selecting a GCS from the library, by selecting a 
GCS from an attached reference, by selecting a GCS from an unrelated design, and by creating a GCS from placemarks 

Geographic coordinate system (GCS) can be selected from MicroStation’s extensive library of predefined GCSs.  This is useful 
in the following cases: Existing data was drawn in a geographic coordinate system and you want to make MicroStation aware of 
that GCS.  Data is correctly drawn in one specified GCS, but you want to reproject the data to a different GCS.  Or, you want to 
designate the GCS to a new design file. 

The following exercise illustrates how to apply a geographic coordinate system to a model. 

 

 

 

Exercise:  Create a Geographic Coordinate System by choosing from the library 

1. Remain in the Geospatial project and open /designs/BSI200-R03-Public Works.dgn 

2. Review the existing geographic coordinate system by choosing Tools > Geographic > Select Geographic Coordinate 
System. 

This model is set to NAD27, UTM Zone 17N 
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3. Remaining in this file, create a new 2D design model and notice the absence of a GCS. 

 

 

 

 

4. If needed, select Tools > Geographic > Select Geographic Coordinate System 

5. Select From Library and explore the library contents. 

6. Using the Search tab, look for LL83, ensure that it’s selected and click OK. 

 

An information dialog will open which warns that the storage units of the model are different than the select coordinate 
system.   

 

7. Choose the top option: 

 

8. Save the settings. 

 

MicroStation can reproject design data from one geographic coordinate system to another. This can be done permanently or 
temporarily, depending whether the GCS came from the active model or a referenced model. There are different situations in 
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which you may have to reproject the design data:  When assigning a geographic coordinate system to a model that already has a 
GCS assigned.  And, when attaching a reference model that uses another GCS than the active model to which it is attached. 

When attaching a reference model that uses another geographic coordinate system than the active model to which it is being 
attached, MicroStation can reproject the design data in the reference model. This is being done only temporarily; the changed 
data are not written back to the referenced file. Because MicroStation knows the exact geographic location and orientation of 
both models, it can calculate the coordinates in the master model of any reference model point, as long as the geographic area 
of the reference model is within the useful range of the master model's geographic coordinate system. 

In the following exercise, a reference will be attached and reprojected. 

Exercise:  Reproject a reference 

1. Continuing in BSI200-R03-Public Works.dgn, choose Attach Reference  

2. Select the current file:  BSI200-R03-Public Works.dgn, using the Interactive attachment mode. 

3. Ensure that the Streets model is selected, set the orientation to Coincident, and turn on Live Nesting. 

 

 

4. Click OK and fit the view. 
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The reference dialog provides important feedback regarding the attachment. In this case, it’s attached coincidentally and the 
GeoCS column shows in red.  This indicates that the model is not georeferenced to the coordinate system of the active 
model which is LL83. 

 

5. Change the Georeferenced option to Reprojected and fit the view if necessary.   

 

The reference is reprojected to align with the coordinate system of the active model.  This change is done in memory only; 
the physical graphics do not change location.  

 

 

Note:  This change can also be made upon the initial attachment or directly from the Orientation column of the Reference dialog. 

In the event that the graphics are not reprojecting as expected, it may be necessary to adjust the Reprojection Settings: 
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When you select the Geographic ‐ Reprojected orientation option in the Reference Attachment Settings dialog, it projects all data 
in the reference model from the reference model’s geographic coordinate system to the active model’s geographic coordinate 
system. The reprojected data is stored only in memory, since the reference is not changed, so the reprojection calculations 
happen each time the reference is loaded. This increases the time required to open the active model. 

In the following exercise, the coordinates will be displayed in the status bar. 

 

Exercise:  Adjust display of coordinates 

1. Continuing in the same file, right click on the right side of the status bar and enable the display of Running Coordinates. 

 

 

As the pointer moves around the map, the status bar displays the latitude and longitude coordinates. 
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Data points can be entered in longitude, latitude by setting the active ACS to the geographic coordinate system and using the 
key-in POINT ACSABSOLUTE. You can enter the longitude and latitude in any of the following formats. 

12.345 = 12.345 degrees 

12^34.5 = 12 degrees, 34.5 minutes 

12:34.5 = 12 degrees, 34.5 minutes 

2d34.5 = 12 degrees, 34.5 minutes 

12d34.5m = 12 degrees 34.5 minutes 

12:34´56.7 = 12 degrees, 34 minutes 56 seconds 

12:34´56.7” = 12 degrees, 34 minutes 56 seconds 

12:34:56.7 = 12 degrees 34 minutes, 5675.7 seconds 

12d34m56.7 = 12 degrees 34 minutes, 56.7 seconds 

12d34m56.7s = 12 degrees 34 minutes, 56.7 seconds 

 

 

Exercise: Display and enter coordinates in longitude, latitude format 

1. Continuing in BSI200-R03-Public Works.dgn, navigate back to the Streets model. 

2. Select Copy Element. 

3. Snap to the endpoint of a line. 

Note the coordinates in the right part of the status bar are similar to these: 711123.6152, 4902352.7432.  The Cartesian XY 
coordinates of every point in the map are projected on the assigned geographic coordinate system.  If a geographic coordinate 
system is assigned to a model, it appears in the Auxiliary Coordinates dialog. When it is made the active auxiliary coordinate 
system, data can be entered in longitude, latitude format, and coordinate readout can be set to show longitude and latitude. 

4. Select Utilities > Auxiliary Coordinates. 

5. In the Auxiliary Coordinates dialog, double click the geographic coordinate system in the list to make it the active auxiliary 

coordinate system.  

6. To set the coordinate readout to show longitude and latitude, left click the coordinates field in the status bar and select ACS 

Position. 
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7. Select Copy Element and snap to the same endpoint again. The coordinates are displayed now in longitude, latitude format: 

-78.3558° , 44.2458° . Negative values for longitude indicate western hemisphere, and negative values for latitude indicate 

the southern hemisphere. 

8. To change the readout of the coordinates select Settings > Design File > Angle Readout category. 

9. Set the format to DD MM SS and the accuracy to 0.12, and then click OK. 

10. View the coordinates again.  They’re displayed in degrees, minutes, and seconds.  

 

You will enter a point with coordinates in longitude, latitude format. 

 

11. Select Place Circle and move the input focus to the AccuDraw window by pressing the space bar. 

12. Type the AccuDraw shortcut M or P to open the Data Point Keyin dialog. 

13. Select ACS (ax=) from the menu to enter ACS dependent coordinates. 

14. To define the center of the circle type the following coordinates and press Enter: 

-78°20, 44°19 

(To type a degree symbol °, press Alt + 0176 on the numeric pad of the keyboard.) 

15. Click in the view to define the radius of the circle. 
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Drawing models - A new model type called a drawing model is now available. The Drawing model is an intermediate model 
between the 3d model and the Sheet model. It is the first place one would need to start thinking about annotation and output 
scale. It is also bigger than a sheet, meaning it is used to layout annotate information or setup design information that spans 
multiple sheets. It does not contain a border. 

Some of the important properties of a drawing model are as follows. 

• A drawing model is always 2D. 

• It does not have a sheet boundary. 

• The default background color of a drawing model is gray. 

• A reference attached to a drawing model is 1:1 coincident. 

• Drawing titles should not be placed in a drawing model because their fields cannot be updated. 

• Annotations can be placed in a drawing model. 

• You can pre-specify the detail scale of a drawing model. When a drawing model is attached to a sheet, the drawing model's 
annotation scale is used as the attachment's default detail scale. 

 

Dynamic Views - The term dynamic views refers to a method of composing drawings that is a new approach to managing 
projects. Dynamic views can help you to do the following:  automate sheet creation, keep MicroStation files up to date by 
creating responsive drawings, eliminate errors in design and documentation and manage changes across MicroStation files. 

The delivered Drawing Composition workflow is critical to understanding dynamic views. This workflow is designed to take you 
through the process from beginning to end, so tasks are arranged in the Tasks dialog from top to bottom.  Tasks are arranged in 
order in the Tasks dialog, from top to bottom. 

 Organize the project data. At this stage, you use Project Explorer, which is a catalog of your project resources or a 
hyperlinked table of contents.  

 The Drawing task is in every workflow. It is there to help you with any other drawing activities. 
 Design Composition. At this stage, you create a collection of references at full scale (1:1) to use in several designs, design 

compositions, or sheet compositions. 
 Create Views (2D). At this stage, you compose all the section, detail or plan views in the project. These views should have 

linked callouts and placeholder fields so that, when the views are added to a sheet, they are automatically updated as work 
commences. 

 Sheet Composition. At this stage, you create sheets that represent finished geometric work ready for publication. Typically, 
this is where print scale is taken into consideration. 

 Annotate. Add final annotations such as any informational geometry, hatching, dimensions, callouts, and text to the sheet to 
produce a finished product. 
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In the following exercise, dynamic views will be explored. 

Exercise: Exploring dynamic views 

1. Set the following in the File Open dialog: Project: General 

2. Open Drawing Composition.dgn. 

This file shows the effects of dynamic views, contained in a single file. All models are in this file, and all references are 
models in this file. This is not a typical work flow, but lets you see the effects easily. 

3. Make the Drawing Composition workflow active in the Tasks dialog. 

4. Click View 4’s title bar to make it the active view. 

5. Select Element Selection and select the horizontal section line. 

 

 

 

 

 

Note that the dashed boundary around the area is the clip volume 

6. Move a handle to change the position of the section line. Note that the other views update. 

7. Click the vertical section line.  

 

 

 

 

 

 

 

 

8. Select and move the green arrow on the vertical section line and observe the results. 

9. Right click on the green arrow and select Flip Direction. Now you can move the other way. 
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10. Select one of the clip volume’s bolt handles of the and move it to see the graphics update 

 

 

Note:  Bolt handles show the area up to the clip volume, but not beyond. Arrow handles will show beyond the clip volume. 
Toggle between both handle types by right clicking the handle and selecting Toggle Cropping. 

11. Open the various models and examine each model’s References, Saved Views, Clip Volumes, and View Attributes. 

 

Exercise: Add a detailing symbol 

1. Continuing in Drawing Composition.dgn, click the Annotate task. 

2. Select Place Elevation Callout, with the following tool settings: 

Detailing Style: Default 

Preserve Up: Enabled  

Create Dynamic View: Enabled 

Annotation Scale lock: Enabled 

3. In View 1, the Plan model, select the outer wall on the lower left side. 
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4. Place the elevation callout to the left of the building by entering a data point. 

5. Drag to the right, past the other side of the building, to establish the clip volume, and enter a second data point.  The Create 
Dynamic View dialog opens. 

6. In the Create Dynamic View dialog, turn on Create Saved View. 

7. Change the Name to East Elevation and click OK. 

 

 

8. Open the Saved Views dialog to see that the East Elevation saved view was created. 

 

 

  

Exercise: Test dynamics 

1. Continuing in Drawing Composition.dgn, create a new Sheet model: 

Type: Sheet from Seed  

Seed Model: general.dgnlib, SheetSeed 

Name: East Elevation 

Annotation Scale: 1:250 

Update Fields Automatically: Enabled 

Sheet Name: East Elevation 

Sheet Number: 10 
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Note:  If the border attachment fails to show, turn on Live Nesting.  

 

2. In the East Elevation model, open the Saved Views dialog. 

3. Drag and drop East Elevation into View 1. 

 

4. Set the following in the Reference Attachment Settings dialog:  

Detail Scale: 1:20 

Level: Reference Object 

Synchronize with Saved View: Enabled 

Use Active Annotation Scale (Toggle): Enabled 

Drawing Title: Create: Enabled 

Drawing Title Name: East Elevation 

5. Click OK and position the view on the sheet. 

6. Return to the previous model. 

7. In View 4, open the View Attributes dialog. 

8. Set Models to East Elevation. 

9. In View 1, Plan, right click on the Elevation callout and choose Rotate. 

10. Rotate the callout by 120 degrees and note the effect on View 4. 

11. Close the file. 

The dynamic views workflow can be automated using the Create Dynamic View dialog. Different workflows can be completed by 
using the Create Saved View, Create Drawing, and Create Sheet check boxes. The dialog opens when you use any of the 
following tools and the Create Dynamic View check box is enabled in the tool settings; Place Section Callout, Place Detail 
Callout, and Place Elevation Callout, Create Saved View, and Create Clip Volume. 
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Activate Reference: You can edit a reference from within the active model. When a reference is activated, only operations on 
the activated reference are permitted. By default, all elements in other references, as well as the active model, are displayed with 
an override color. You can control whether or not an override color is used, and what the color is, with the Active Reference 
Override Color preference (Workspace > Preferences Reference category, Active Reference Override Color 

 

 Exercise: Activate a reference for in-place editing 

Set the following in the File Open dialog:  

Project: Civil 

Open /Drawings/BSI400-HorizontalAlignmentDrawing.dgn. 

1. With Element Selection active, right press on a curve representing the creek and select Activate 

2. Change the creek to colour 7, weight 2. 

3. Change the tree line to colour 2, weight 2 

4. Right click on a changed element and choose Deactivate 

5. Close the file 

 

References and levels - You can attach a reference to a level in the DGN workmode. This option is critical when attaching a 
saved view as a reference. The reason is that a saved view can only store the reference level setting of a reference attachment. 
To keep the saved view and reference synchronized, you must choose a level when attaching a saved view as a reference. 

 Exercise: Using saved views, references and levels to synchronize 

1. Change the workspace project to Building 

2. Create a new 3D file in the /sheets/ folder. 

3. Use ...\Workspace\System\seed\seed3d.dgn as the seed file, and name the file Saved View as Reference.dgn. 

4. In the Models dialog, create a new sheet model: 

Type: Sheet 2D  

Name: Saved View 

Scale: Full Scale 

5. Open the References dialog. 
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Attach \Drawings\BSI300-GroundFloorPlan.dgn with the following attachment settings: 

Model: Ground Floor Plan 

Orientation: Saved Views > PlanClip 

Detail Scale: 1:50 

Level: Markup 

Nested Attachments: Live Nesting Depth: 3 

Synchronized with Saved View: Enabled 

Drawing Title > Create: Enabled 

Drawing Title Name: Corner Plan 

6. Place the reference in the center of the sheet. 

7. Note the corner column and the detail marker.  Note there is no text on the saved view. 

8. Open \Drawings\BSI300-GroundFloorPlan.dgn. 

9. Zoom in to the lower left corner so you can see the text. 

10. Select Utilities > Saved Views. 

11. Double click PlanClip to apply it to View 1. 

12. Turn on A-Z000-G-Anno and Z-Z001-G-Iden levels. 

13. Zoom out if necessary to see the changes. 

14. Select PlanClip and click Update Saved View Settings in the Saved Views dialog.   

15. Turn on Update Camera Position 

16. Enter a data point in the view. 

17. Return to the sheet model in the new file to see that the referenced saved view has updated. 

18. Select File > Close when you are done. 
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3D Design Modeling - Most of the 3D modeling tools have been reorganized with separate toolboxes for solids and surfaces, 
features and meshes.  

 

  

For example, in previous versions of MicroStation, you had the choice of making a 3D 
primitive either a solid or a surface.  In MicroStation V8i, this option has been split into two 
separate tool boxes:  Primitive Solids and Primitive Surfaces. 

Several solid modeling tools have been enhanced and new tools have been included for creating and modifying solids.  For 
example four new solid primitives have been added:  Pyramid, Elliptical Cone, Ellipsoid and 
Polyhedron. 

In the following exercises, several 3D tools will be explored. 

Exercise:  Pyramid Solid 

1. Continuing in the Examples/General workspace, open Solids.dgn. 

2. Hover the pointer over the 3D object in the top right 
tile, and select Exchange from the right-click menu. 

3. To assist with the visualization of the objects, set the 
View Display Style to Illustration. 

4. From the Solids Modeling task, choose Pyramid 
Solid from the Primitive Solids tool box.  Or choose  
Tools > Solids > Primitive Solids > Pyramid with the 
following settings: 

Method: Rectangle 

Orthogonal: Enabled 

Base Length: 1200 

Base Width:  700 

Height: 500  

5. Follow the prompts; enter a data point to define the length. 

6. Enter a data point to define the width. 



                   IBUG Fall User Group Meeting September 28th 2011 
 

        © 2011 Bentley Systems, Incorporated.    
     

36

 

 

7. Enter a data point to define the height.  

8. Enter a data point to define the top width. 

9. Finally, enter a data point to define the top length. 

 

 

 

 

 

 

 

 

 

The following new Solid Modeling Tools have been added:  Linear Solid, Replace Face, and Draw On Solid. 

 

Exercise:  Linear Solid 

1. Continue in the Primitives model of Solids.dgn 

2. Select Linear Solid from the Create Solids tool box.  Or choose Tools > 
Solids > Create Solids > Linear Solid 

3. Use the following settings: 

Place By: Outside 

Width:  100 

Height:  500 

 

4. Follow the prompts and enter a series of data points to define the shape of the solid.  
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All 3D modeling tools now have a unified workflow that covers that way that you select items for creation and modification and 
how you can modify them interactively.  You can select edges and faces for 
modification, and use interactive handles to control 3D objects. 

 

Exercise:  Draw on Solid / Pull Edge 

1. Open 3D Push Pull Modeling.dgn. 

2. Navigate to the model titled Draw Line on Solid 

3. From the Modify Solids toolbox, choose Draw on Solid (Tools > Solids > Modify Solids > Draw on Solid) 

4. Adjust the setting to be Draw Line with Edge to Edge enabled. 

 

 

5. On the left solid, enter a two data points from edge to edge on the top face.  

6. From the Modify Solids tool box, choose Modify Solid Entity with the following settings:  Mode:  Edge and Full Dynamics: on 

 

7. Follow the prompts, select the edge to modify and enter a data point to fix its new location. 
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The following new surface modeling tools are located in the Create Freeform Surfaces, Modify B-spline Surfaces and Surface 
Utilities tool boxes:  Loft Surface by Vertices, Surface by Edge Curves, Surface by Corner Points, Surface Handlebar, Twist 
Surface, Planar Slice, Unroll Developable Surface, Mesh modeling creation and modification tools. 

 

Exercise:  Surface by Corner Points / Surface Handlebar 

1. Open 3D – Surfaces.dgn and navigate to any of its design models. 

2. From the Surface Modeling task, choose Surface by Corner Points  from the Create Freeform Surfaces tool box. (Tools > 
Surfaces > Create Freeform Surfaces > Surface by Corner Points). 

 

 

 

 

3. Follow the prompts and define four corners. 

 

 

 

4. From the Modify B-spline Surfaces tool, choose the Twist Surface tool.  The settings can remain unchecked. 

 

5. Identify the B-spline surface or mesh element. 

6. Enter a data point to define the start of the axis.  For example, the lower left corner. 
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7. Enter a data point to define the end of the axis.  For example, the lower right corner. 

 

 

 

 

 

8. Enter a data point to define the reference point for the start of the twist.  For example, the upper right corner. 

 

 

 

 

 

9. Enter a data point to define the end reference point for the twist. 
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Design Review - To facilitate the design review process, MicroStation allows you to view markup elements, such as annotation 
text, freehand redlining, pen and area highlighting.   

You can use MicroStation to view markups made by ProjectWise Navigator. 

The Markups dialog is used to view markups made in a design by ProjectWise Navigator. A markup can be annotation text, 
freehand redlining, pen and area highlighting. 

The Markups dialog is divided into two sections. The top section displays information about the markup. The bottom section 
automatically displays any changes made to the properties of the markup. 

 

If you use MicroStation to open an *.overlay.dgn file, the Markups dialog offers additional options such as deleting a markup or 
switching to a review mode. Used to:  manage all the markups in an overlay file, add and manage comments for the markups, 
activate markups by double-clicking the markup in the list box. Double-clicking a markup opens a preview window, which 
displays the model and the markup information.  

 

i-Models - A Bentley i‐model is a container for open infrastructure information exchange and enables bi‐directional feedback in 
dynamic workflows.  An i‐model can be information‐rich meaning that it contains geometry as well as all business data which 
does not require the source application to be available.  You can compose information‐rich i‐models from multiple 2D and 3D 
geometry and data sources in a single lightweight container. Every i‐model is self describing, which means that source 
application features are not required to display or describe the business information stored within. 

 

Exercise: Publish a file 

1.  Set the following in the File Open dialog: 

User: examples 

Project: Building 

2. In the \Designs folder, open Design-Composition.dgn  

 

3. Open the references dialog and take note of the references listed. 

 

4. Select File > Publish i-model. 

 

5. Enable both Force republishing of all files and Create a Package 
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6. Click OK. The files are processed. 

 

7. Select File > Close. 

 

8. Delete all the dgn.i.dgn files except the package Design-Composition.i.dgn. 

 

9. Open Design-Composition.i.dgn. 

 

10. Note the file contents. 

 

11. Open the references dialog and take note of the references listed. 

 

12. The referenced files are .i.dgn files. Even though the actual files were deleted, the package file contains the data. 

 

13. Close the file. 

 

 

Thank you! 


